А7

Тема:  Электронные таблицы.

Что нужно знать:

·    адрес ячейки в электронных таблицах состоит из имени столбца и следующего за ним номера строки, например, C15

·    формулы в электронных таблицах начинаются знаком = («равно»)

·    знаки +, –, *, / и ^ в формулах означают соответственно сложение, вычитание, умножение, деление и возведение в степень

·    запись B2:C4 означает диапазон, то есть, все ячейки внутри прямоугольника, ограниченного ячейками B2 и C4:


·    например, по формуле =СУММ(B2:C4) вычисляется сумма значений ячеек B2, B3, B4, C2, C3 и C4

·    в заданиях ЕГЭ могут использоваться стандартные функции СЧЕТ (количество непустых ячеек), СУММ (сумма), СРЗНАЧ (среднее значение), МИН (минимальное значение),  МАКС (максимальное значение)

·    функция СРЗНАЧ при вычислении среднего арифметического не учитывает пустые ячейки и ячейки, заполненные текстом; например, после ввода формулы в C2 появится значение 2 (ячейка А2 – пустая):


функция СЧЕТ(A1:B2) в этом случае выдаст значение 3 (а не 4).

·    адреса ячеек (или ссылки на ячейки) бывают относительные, абсолютные и смешанные, вся разница между ними проявляется при копировании формулы в другую ячейку:

o   в абсолютных адресах перед именем столбца и перед номером строки ставится знак доллара $, такие адреса не изменяются при копировании; вот что будет, если формулу =$B$2+$C$3 скопировать из D5 во все соседние ячейки


знак $ как бы «фиксирует» значение: в абсолютных адресах и имя столбца, и номер строки зафиксированы

o    в относительных адресах знаков доллара нет, такие адреса  при копировании изменяются: номер столбца (строки) изменяется на столько, на сколько отличается номер столбца (строки), где оказалась скопированная формула, от номера столбца (строки) исходной ячейки; вот что будет, если формулу =B2+C3 (в ней оба адреса – относительные) скопировать из D5 во все соседние ячейки:


o   в смешанных адресах часть адреса (строка или столбец) – абсолютная, она «зафиксирована» знаком $, а вторая часть – относительная; относительная часть изменится при копировании так же, как и для относительной ссылки:


Пример задания:

В ячейке B4 электронной таблицы записана формула = $C3*2. Какой вид приобретет формула, после того как ячейку B4 скопируют в ячейку B6? Примечание: знак $ используется для обозначения абсолютной адресации.

1)  =$C5*4             2) =$C5*2                        3) =$C3*4                  4)  =$C3*2

Решение:

1)      ссылка $C3 – это смешанная ссылка, в которой «заблокирован» столбец C, а строка 3 – это относительный адрес;

2)      после того, как ячейку B4 скопировали в B6, номер строки увеличился на 2, поэтому и в ссылке $C3 номер строки (относительная часть) также увеличится на 2, ссылка превратится в $C5

3)      константы при копировании формул не меняются, поэтому получится =$C5*2

4)      таким образом, правильный ответ – 2.

Возможные ловушки и проблемы:

·    если ошибочно посчитать, что знак $ защищает от изменений всю ссылку, получим неверный ответ 4

Ещё пример задания:

Три страны: Королевство Бельгия, Королевство Нидерланды и Великое Герцогство Люксембург образуют экономико-политический союз, который носит название Бенилюкс. Ниже приведен фрагмент электронной таблицы, характеризующий каждую из стран союза и союз в целом:

 

А

B

C

D

1

Страна

Население
(тыс. чел)

Площадь
 (кв. км)

Плотность населения (чел / кв.км)

2

Бельгия

10 415

30 528

341

3

Нидерланды

16 357

41 526

394

4

Люксембург

502

2 586

194

5

Бенилюкс в целом

27 274

74 640

 

Какое значение должно стоять в ячейке D5?

1) 365       2) 929                   3)  310                  4)  2,74

Решение:

5)      нужно не забыть, что плотность населения вычисляется как отношение населения к площади (не наоборот!);

6)      население не забываем перевести из тысяч человек в единицы: 27 274 000 чел

7)      поэтому для всего Бенилюкса получаем 27 274 000 / 74 640 ≈ 365

8)      таким образом, правильный ответ – 1.

Возможные ловушки и проблемы:

·    в такой простой задаче есть сильная ловушка: ответ 4 (2,74) получается при «обратном» делении, то есть 74 640 / 27 274  ≈ 2,74

Еще пример задания:

В электронной таблице значение формулы =СУММ(B1:B2) равно 5. Чему равно значение ячейки B3, если значение формулы =СРЗНАЧ(B1:B3) равно 3?

1)  8                          2) 2                                     3) 3                               4)  4

Решение:

1)      функция СУММ(B1:B2) считает сумму значений ячеек B1 и B2, поэтому B1 + B2 = 5

2)      функция СРЗНАЧ(B1:B3) считает среднее арифметическое диапазона B1:B3

3)      строго говоря, такие задачи некорректны, потому что

а)      функция СРЗНАЧ учитывает только числовые данные (числа или формулы, при вычислении которых получается число), то есть возможны варианты:

СРЗНАЧ(B1:B3)=СУММ(B1:B3), если есть только одна числовая ячейка

СРЗНАЧ(B1:B3)=СУММ(B1:B3)/2, если есть две числовых ячейки

СРЗНАЧ(B1:B3)=СУММ(B1:B3)/3, если все три ячейки – числовые

б)      в условии не задано, сколько числовых ячеек в диапазоне B1:B3

4)      в такой ситуации логичнее всего считать, что все три ячейки содержат числовые данные (во всех известных автору задачах такого типа используется именно это допущение)

5)      итак, в диапазон B1:B3 входят три ячейки; предполагаем, что все они содержат числовые данные, тогда  среднее арифметическое – это сумма их значений, деленная на 3; таким образом B1 + B2 + B3 = 3 · 3 = 9

6)      поскольку B1 + B2 = 5, сразу получаем B3 = 9 – 5 = 4

7)      таким образом, правильный ответ – 4.

Возможные ловушки и проблемы:

·    чтоб сбить угадывание, среди ответов приведены сумма исходных данных (8) и их разность (2) , это неверные ответы

Еще пример задания:

Дан фрагмент электронной таблицы:

 

А

В

С

1

10

20

= A1+B$1

2

30

40

 

Чему станет равным значение ячейки С2, если в нее скопировать формулу из ячейки С1? Знак $ обозначает абсолютную адресацию.

 1) 40                        2) 50                            3)60                             4) 70

Решение:

1)      это задача на использование абсолютных и относительных адресов в электронных таблицах

2)      вспомним, что при копировании все относительные адреса меняются (согласно направлению перемещения формулы), а абсолютные – нет

3)      в формуле, которая находится в C1, используются два адреса: A1 и B$1

4)      адрес A1 – относительный, он может изменяться полностью (и строка, и столбец)

5)      адрес B$1 – смешанный, в нем номер строки «зафиксирован» знаком доллара, а имя столбца – нет, поэтому при копировании может измениться только имя столбца

6)      при копировании из C1 в C2 столбец не изменяется, а номер строки увеличивается на 1, поэтому в C2 получим формулу =A2+B$1 (здесь учтено, что у второго адреса номер строки «зафиксирован»)

7)      сумма ячеек A2 и B1 равна 30 + 20 = 50

8)      таким образом, правильный ответ – 2.

Возможные ловушки и проблемы:

·    расчет на то, что ученик забудет, что абсолютная ссылка не меняется (тогда получится формула =A2+B$2, на этот случай дан неверный ответ 70)

 

Еще пример задания:

Дан фрагмент электронной таблицы:

 

А

В

С

1

1

2

 

2

2

6

=СЧЁТ(A1:B2)

3

 

 

=СРЗНАЧ(A1:C2)

Как изменится значение ячейки С3, если после ввода формул переместить содержимое ячейки В2 в В3? («+1» означает увеличение на 1, а «–1» – уменьшение на 1)

 1) –2                       2) –1                            3) 0                              4) +1

Решение:

1)      это задача на знание особенностей функций СЧЕТ и СРЗНАЧ, которые не учитывают пустые ячейки

2)      после ввода формул в С2 окажется количество непустых ячеек диапазона А1:В2, равное 4

3)      в С3 будет выведено среднее значение диапазона А1:С2 равное

         (1+2+2+6+4)/5 = 3

4)      после перемещения (не копирования!) содержимого ячейки В2 в В3 ячейка В2 окажется пустой, поэтому в С2 выводится число 3 – количество непустых ячеек диапазона А1:В2

5)      в С3 будет выведено среднее значение диапазона А1:С2 равное

         (1+2+2+3)/4 = 2,

то есть значение С3 уменьшится на 1

6)      таким образом, правильный ответ – 2.

Возможные ловушки и проблемы:

·    нужно помнить, что при перемещении содержимого ячейки в другое место она становится пустой

·    нужно помнить, что функции СЧЕТ и СРЗНАЧ не учитывают пустые ячейки

 

Comments